pt/postgresql error? unable to connect to server

Forum with tips, support, etc, on using the PostgreSQL database with Poker Tracker. Please post any PostgreSQL questions here.

pt/postgresql error? unable to connect to server

Postby phantom_lord » Fri Aug 22, 2008 4:39 pm

When i tried using pokertracker today all i got was this error:

[ img ]






*********************************

PT Version: 2.17.01k
Error Date: 08/22/2008 20:20
Database Error: -1
Error Text: Database transaction information not available.

Call SetTrans or SetTransObject function.
DataObject: d_dd_game_level
*********************************

*********************************
PT Version: 2.17.01k
Error Date: 08/22/2008 20:41
Database Error: 101
Error Text: SQLSTATE = 08001
could not connect to server: Connection refused (0x0000274D/10061)
*Is the server running on host "localhost" and accepting
*TCP/IP connections on port 5432?

Object: ue_opendatabase event of w_frame
*********************************



I haven't changed any settings from last time i used pt, all i did was purge some old hands from the database.

any idea of what to do?
phantom_lord
 
Posts: 9
Joined: Fri Aug 22, 2008 4:37 pm

Re: pt/postgresql error? unable to connect to server

Postby phantom_lord » Fri Aug 22, 2008 4:49 pm

I tried starting postgre using control panel -> services, but that made no difference. i still get the same error,

also there's no postmaster.pids file on my computer for me to delete only postmaster.opts.

I'm using 8.2 should i upgrade to 8.3?
phantom_lord
 
Posts: 9
Joined: Fri Aug 22, 2008 4:37 pm

Re: pt/postgresql error? unable to connect to server

Postby ptrack pat » Fri Aug 22, 2008 6:35 pm

Is the service running? What happened when you tried to start it from the control panel?

Is this Vista you are using? Go to Start > All Programs > PostgreSQL 8.2 > pgAdmin III
Right-click on the red X near the top left of the window and select connect from the popup menu.
Enter your p/w - what happens? Does this give an error too?

When did you last backup the database?
ptrack pat
 
Posts: 4841
Joined: Sun Dec 09, 2007 12:38 pm

Re: pt/postgresql error? unable to connect to server

Postby phantom_lord » Fri Aug 22, 2008 6:42 pm

i get no problems when i start the service from the control panel. but i still get the same error from pt

when i try connecting in pgaAdmin III i get this pop-up

"Server doesn't listen
The server doesn't accept connections: the connection library reports
could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432?
If you encounter this message, please check if the server you're trying to contact is actually running PostgreSQL on the given port. Test if you have network connectivity from your client to the server host using ping or equivalent tools. Is your network / VPN / SSH tunnel / firewall configured correctly?
For security reasons, PostgreSQL does not listen on all available IP addresses on the server machine initially. In order to access the server over the network, you need to enable listening on the address first.
For PostgreSQL servers starting with version 8.0, this is controlled using the "listen_addresses" parameter in the postgresql.conf file. Here, you can enter a list of IP addresses the server should listen on, or simply use '*' to listen on all available IP addresses. For earlier servers (Version 7.3 or 7.4), you'll need to set the "tcpip_socket" parameter to 'true'.
You can use the postgresql.conf editor that is built into pgAdmin III to edit the postgresql.conf configuration file. After changing this file, you need to restart the server process to make the setting effective.
If you double-checked your configuration but still get this error message, it's still unlikely that you encounter a fatal PostgreSQL misbehaviour. You probably have some low level network connectivity problems (e.g. firewall configuration). Please check this thoroughly before reporting a bug to the PostgreSQL community. "


yep i'm using vista. and i haven't backedup the database for a couple of months :oops:
phantom_lord
 
Posts: 9
Joined: Fri Aug 22, 2008 4:37 pm

Re: pt/postgresql error? unable to connect to server

Postby phantom_lord » Fri Aug 22, 2008 8:32 pm

i did what was recommended in the above pop up but still get the same error msg from pt.
phantom_lord
 
Posts: 9
Joined: Fri Aug 22, 2008 4:37 pm

Re: pt/postgresql error? unable to connect to server

Postby ptrack pat » Fri Aug 22, 2008 9:13 pm

This isn't a PT issue, you get the same error with pgAdmin. Something is preventing these programs from connecting to the server. Are you running any kind of firewall/anti-virus programs that you just installed/updated? Did you do any Windows updates or anything recently?
ptrack pat
 
Posts: 4841
Joined: Sun Dec 09, 2007 12:38 pm

Re: pt/postgresql error? unable to connect to server

Postby phantom_lord » Fri Aug 22, 2008 11:45 pm

ok. no nothing's been changed, my computer got shut down by a power outage, that's about the only thing i can think of that has happened since i last used pt.

i disabled my av, and firewall, and still got the same error.
phantom_lord
 
Posts: 9
Joined: Fri Aug 22, 2008 4:37 pm

Re: pt/postgresql error? unable to connect to server

Postby ptrack pat » Sat Aug 23, 2008 12:16 am

If you don't have any recent backups then this is what you will need to do to try to recover the databases...

1. Create a new folder on your C drive called PostgreSQL_Data.
2. Go to the c:\program files\postgresql\8.2 folder. Right-click on the "data" folder and select "Copy" from the popup menu.
3. Go to the newly created c:\PostgreSQL_Data folder and right-click and select "Paste" from the popup menu.
4. Now, go to the Start menu and select Settings > Control Panel > Add or Remove Programs and then remove PostgreSQL 8.2 from the list.
5. From the Start menu again select Run. On the window that opens type "COMMAND" and hit OK. This will open a DOS window. Type the following next to the prompt...

net user postgres /delete

and hit ENTER to run it. Then type EXIT to close the DOS window.

6. Now, download and reinstall PostgreSQL as directed here:
http://www.pokertracker.com/products/PT ... nstallSQL2

WITH THE EXCEPTION THAT on the second window where it asks you where you want to install PostgreSQL click on the "Data Directory" button and navigate to the c:\PostgreSQL_Data\data folder and select that. This will force it to try to reuse your old data.

CONTINUE until you get to the window that has the "Initialize Database Cluster" box at the top left corner. UNCHECK THIS BOX and click the Next button and then just continue installing from there.

7. Once the install is done, RESTART YOUR COMPUTER and then try to open PT again.
ptrack pat
 
Posts: 4841
Joined: Sun Dec 09, 2007 12:38 pm

Re: pt/postgresql error? unable to connect to server

Postby phantom_lord » Sat Aug 23, 2008 6:56 pm

hi,

i did that, now when i open pt i get this error:


[ img ]

when i try running postgre via control panel -> services i get an error saying it started then stopped.
phantom_lord
 
Posts: 9
Joined: Fri Aug 22, 2008 4:37 pm

Re: pt/postgresql error? unable to connect to server

Postby ptrack pat » Sat Aug 23, 2008 7:17 pm

There is something preventing it from working. Did you turn the UAC back on? Did you try restarting the computer? Is there a postmaster.pid file in the c:\PostgreSQL_Data folder now?
ptrack pat
 
Posts: 4841
Joined: Sun Dec 09, 2007 12:38 pm

Next

Return to PostgreSQL Forum

Who is online

Users browsing this forum: No registered users and 0 guests